Welcome guest, is this your first visit? Create Account now to join.
Results 1 to 2 of 2

This is a discussion on Chrome Unresponsive; Kill pages; Hangs; Loading... within the Chrome Troubleshooting section, part of the Google Chrome category: Windows XP Professional - Service Pack 3 - all uptodate Google Chrome 4.1.249.1021 unknown (40167) On 1st March 2010 I ...


  1. #1
    chromed is offline Junior Member
    Join Date
    Mar 2010
    Posts
    1

    Cool Chrome Unresponsive; Kill pages; Hangs; Loading...

    Windows XP Professional - Service Pack 3 - all uptodate
    Google Chrome 4.1.249.1021 unknown (40167)

    On 1st March 2010 I opted to install Google Chrome. It worked great straight after installation but after restarting my laptop it failed to load any pages. Chrome would attempt to load a page and then give a popup with a message similar to "Pages have become unresponsive" and give the option to Wait or Kill Pages.

    As I only installed Chrome a few days ago from the official Google website I assume it was the latest version release.

    I have now installed the latest Beta release "4.1.249.1021 unknown (40167)". This also works on first installation but following a restart no pages will load, Chrome perpetualy shows the "C Loading..." graphic at the top of the tab page.

    I would like nothing more than to move away from Internet Explorer but am finding Chrome a real pain straight out of the box.

    Any help appreciated.

  2. #2
    DavidStanely is offline Junior Member
    Join Date
    Jan 2012
    Posts
    4

    Default Fix Google Chrome Hangs problem

    Do the following tasks: --Repair and Clean Registry Errors --Repair Flash --Run Scans for Malwares If your browser is hanging or crashing all the time then updating the sound drivers may also help. I also got some help from this article Chrome Hangs. Hope it fix your problem.

Similar Threads

  1. A New problem with chrome loading pages
    By CallMeGod in forum Bugs and Vulnerabilities
    Replies: 17
    Last Post: 09-10-2012, 11:00 AM
  2. Google Chrome Unresponsive ??
    By hanagan in forum Chrome Talk
    Replies: 14
    Last Post: 01-22-2011, 06:54 PM
  3. Slow loading of web pages by Chrome
    By amnesia1@bigpond.com in forum Chrome Troubleshooting
    Replies: 1
    Last Post: 02-15-2010, 08:45 AM
  4. Replies: 0
    Last Post: 03-09-2009, 06:54 AM
  5. Problem loading pages from cache
    By Clark777 in forum Bugs and Vulnerabilities
    Replies: 0
    Last Post: 10-07-2008, 05:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •